Tiberian Sun DLL files missing or damaged

With some versions and distributions of Tiberian Sun, when starting the game you might encounter the Tiberian Sun DLL files missing or damaged popup error AKA:

One or more DLL files were missing or damaged. Please reinstall.

There are a few general steps that you should follow in order to get around this error in most cases:

  1. Make sure you have the TFD freeware version installed. The freeware First Decade version of Tiberian Sun comes fully patched and includes both Tiberian Sun and Firestorm, and is the most common and well supported version of the game out there. It is also bundled with a few patch files that set you up for online play so there’s no reason you shouldn’t be using it at your main installation of the game. You can get the First Decade version from one of the links here.
  2. Make sure the game is installed in the right directory. The First Decade version of Tiberian Sun expects to be downloaded in C:\Program Files\. Your full game path MUST be as follows:
    C:\Program Files\EA Games\Command & Conquer The First Decade\Command & Conquer(tm) Tiberian Sun(tm)\SUN
    If you don’t have the game installed in this directory the included shortcuts and registry patch will not work. You can simply move your extracted EA Games folder to C:\Program Files\ if it isn’t there already.
  3. Run tibsun_regadd.reg. The file is  located in C:\Program Files\EA Games\Command & Conquer The First Decade. This will add the game to your registry thus mimicking a proper install. If this file fails to run you don’t have the game installed in the correct directory.
  4. Run as administrator with Windows 98 compatibility and reduced 16bit color mode. Right click on your Game.exe located in the SUN directory and select properties. Select the compatibility tab check off the following options:
    • Run this program in compatibility mode for: Windows 98 / Windows Me compatibility
    • Reduced color mode: 16-bit (65536) color
    • Run this program as administrator

If you’ve followed the above steps and are still having issues with the Tiberian Sun DLL files missing or damaged error, please post in the comments below. To increase your chances of a solution being found include as much detail as possible (which version of the game you’re running, what operating system you have, what video card you have and steps to reproduce the issue). Screenshots are also very useful!

sources: link 1, link 2, link 3, link 4

Share on Google+0Share on Reddit0Share on StumbleUpon0Tweet about this on TwitterShare on Facebook0Digg this
    Xenoph
    April 22, 2013 at 7:20 am

    I’m running the disc version of the game and I’m having these problems. I’m running windows 8 and all other games on The First Decade work without a hitch. I’ve tried going to the ea support website (they don’t even register TFD as a product anymore) and I found no results to this problem. I’ve also tried running as administer, which also didn’t work, as well as reinstalling the game multiple times. I’ve used this exact copy of TFD on my old laptop and had no problems, so is it just problems with windows 8?

      I don’t have Windows 8 so I can’t speak from experience but the compatibility center looks like what you need. Go there and enable TFD for Windows 95 compatibility and try again. You’ll also want to set the game to run in 16 bit colour mode by selecting the compatibility dialog box under Settings – Reduced Color Mode – 16-bit. You can also look into the Command & Conquer graphics patch, which may help improve framerate if you can get the game running.

    Nawiz
    May 15, 2013 at 1:15 pm

    Hi, I keep having trouble withTS first decade, when i try to open game or sun it tells me “Failed to Initialize please reinstall”. I haven’t seen any installation file. What do i need to do, i really want to play this game. Please help.

    Rizwan Ishtiaq
    September 27, 2013 at 10:09 pm

    While playing the game i have difficulty in opening the menu options
    the bar doesnt opens completely
    When ever i pause the game then the game pauses but that window never appears
    similarly i cant change the map while i am in skirmish menu
    can anyone help me with that plz ????

    sach
    March 19, 2014 at 8:40 pm

    So i’ve tried everything that google has told me to do, including what is here, and it still pops up

      I need a little more info to help you find a solution:

      • What operating system are you running on?
      • What is the full path of you game.exe?
      • Where did you install the game from?

      By far the most common fix to this issue is to set all of your Tiberian Sun executables to run with Win 98 compatibility and as admin (AKA both game.exe and SUN.exe). Also the freeware version of the game is the most well supported and stable. If you don’t have it already you can get it from here:
      http://www.thegameengine.org/tiberian-sun/tiberian-sun-freeware-download/

    March 25, 2014 at 6:11 pm

    I’ve followed all the steps,
    -downloaded the freeware version
    -placed patch files in the correct location
    -ran tibsun_regadd.reg
    -changed compatibility for windows 98 at 16 bits

    Still not working, failed to execute. I’m running windows 8.1

      First make sure that you’re also running the exe files as Admin. This is often a crucial step! If that doesn’t fix it for you, just to double check, are you still experiencing the same DLL error? AKA:

      One or more DLL files were missing or damaged. Please reinstall.

      Or are you now getting a new error?

      Also, to be on the safe side since you didn’t mention it, the registry script should be what you need to get around this error but it will not work if the game is installed in the wrong directory. Your SUN folder MUST be in this exact location, regardless of Windows version if you’re using the TFD install:

      C:\Program Files\EA Games\Command & Conquer The First Decade\Command & Conquer(tm) Tiberian Sun(tm)\SUN

    Tom L.
    April 30, 2014 at 8:50 pm

    So I’m moving over to this thread from the Windows 8 thread I posted in yesterday and today, since I’m consistently getting this error…

    I tried downloading the freeware from another link (http://www.fileplanet.com/210105/210000/fileinfo/Command-&-Conquer:-Tiberian-Sun—Full-Game-Client) which I needed to install WinRar to unzip. That did include “tibsun_regadd”. Ran it and it said it was added successfully but didn’t help. Tried completely uninstalling the first decade (tried uninstalling & reinstalling this game multiple times when troubleshooting). I reinstalled, replaced Command & Conquer(tm) Tiberian Sun(tm) folder with the new freeware version I downloaded. Ran the “tibsun_regadd”. Replaced “ddraw.dll”, “libwine.dll”, & “wined3d.dll” in the SUN folder with same files from Win8fix. Then made sure the “Game” and “SUN” application files in the SUN folder were set to Windows 98/ME compatibility, 16 bit color, and run as administrator. Also seen there was an application I didn’t see before, “clokspl” which is in the SUN folder. Tried making sure that was set to 98/ME compatibility, 16 bit color, and run as administrator. Seems like Tiberian sun gets a few seconds closer to launching but still gives “One or more DLL files were missing”.

    Tom L.
    April 30, 2014 at 9:24 pm

    Tried Command & Conquer graphics patch (http://www.stuffhost.de/files/cnc/CnCPatcher.html). Copied “SUN” & “Game” application files into the same folder as “CnCGraphicsPatch” application after downloading it. Ran it and it says “No patch applicable. Please copy the ame file (game.exe or gamemd.exe) into this folder first. Still has “Apply patch”, “Deactivate patch”, & close buttons. Tried Apply patch button and nothing happens. The instructions say “You will need the Microsoft .net Framework 3.5 to run this tool, checked “Turn Windows features on or off” and .NET Framework 3.5 is enabled.

    Tom L.
    April 30, 2014 at 9:27 pm

    Tried moving the “SUN” & “Game” application files back to “SUN” folder anyway, and still get the missing DLL files error.

    NIck
    May 14, 2014 at 6:03 pm

    Well I have command and conquer the first decade and I also have the unofficial patch installed as well. the game won’t run when i click on the tiberian sun icon in the menu. but when I open the directory where its installed and run SUN, it runs perfectly fine

      Can you check where the menu icon points to? (right click, properties). My guess is either it points to another install/location other than your working Tiberian Sun install, or it has some additional configurations under the compatibility tab in the properties window that are causing a startup crash.

    June 23, 2014 at 3:51 am

    I did all that stuff, game started, but got the menu problem where i couldn’t click anything. So i installed the win 8 fix, pasted the 3 dll files, and then the game won’t start at all saying’ Main executable won’t start’

    September 9, 2014 at 8:18 pm

    Same error, been doing all that has been posted. i run Windows 7 and having the same DLL error. any advice?

      Did tibsun_regadd.reg run successfully? Also running as admin is a key part of this, make sure you’re doing that.

      Oddly, some people apparently only get the game to run when you don’t run as admin, so if you haven’t tried that it’s worth a shot.

    Joe C
    November 13, 2014 at 1:57 pm

    Hi Guys,

    Im hoping people will still read this. Ive followed all the intructions and progressed through all the errors. and finally when I got the game to actually look like its launching. I get the failure to initalize error. I have followed all the advice but I wouldnt know how to delete historic registry entries. Please advise

    oh and once DLL’s are in make sure you run it in windows xp compatibility mode, service pack 3 recommended

    Ruddy
    November 23, 2014 at 10:23 am

    the fileplanet link from Tom L. is what finally worked for me on Windows 7

    i coppied it to (c) and clicked on the game icons (run as administrator ) and it works 1 of them have error but the second icon work
    ty

    Andrew
    March 1, 2015 at 10:58 pm

    I dunno if anyone still reads this but I can’t get Tiberian Sun to work. I’m running Windows 7 Home Premium, 64-bit, with SP1. I downloaded the game from Fileplanet, put it in C:\Program Files\EA Games\Command & Conquer The First Decade\Command & Conquer(tm) Tiberian Sun(tm)\SUN and enabled Win 98/ME compatibility and Run as Admin on both Game.exe and SUN.EXE. I ran tibsun_regadd.reg and it completed successfully.

    I DON’T have an option to run in 16-bit in the Compatibility tab, but I’ve tried the other Compatibility options I have like Run in 256 colors etc, but they don’t work either. No matter what I do I still get “One or more DLL files were missing or damaged. Please reinstall.” I even tried downloading the .dll files from Wayne Atkinson’s post, but that yielded the same result.

    I’d like to play this game again but it’s looking impossible… anyone else have tips for fixing this?

      Hi Andrew,

      I’m sorry you’re struggling to get the game to run. I’ve noticed that while these steps seem to work on a wide variety of machines there are a few exceptions like yours that require additional configuration changes.

      The only thing I can suggest past what you have already done is try running the game via both Game.exe and SUN.EXE and see if either works. Also try disabling Run as Admin and compatibility mode changes now that you’ve added the additional .dll files.

      If that still doesn’t work you might want to try and find an alternate installer for the game and do a full reinstall.

      Out of curiosity what video card are you using?

      Also have you been running the game via the included shortcut or just by directly running the exe files?

    jason
    March 21, 2015 at 11:50 am

    okay so everything works until i arrive in the game, im stuck in the menu i press new game it makes the sound as if it worked but it stays frozen on the menu, i tried with options, skirmish any other and it all does the same. is there a way to fix this problem?

    Morgan
    February 20, 2016 at 10:13 am

    I completed all the steps above and was able to get the game to run but when I click the campaign or skirmish button the game freezes. How can I fix this?

Leave a Reply to Joe C Cancel reply

Search
Questions!?
Play nice
>> All posts, unless specified otherwise, are original and created solely for The Game Engine. Please credit anything you use or reference from this site.
Was this site helpful?
>> The Game Engine is a non-profit personal project. Please consider a small donation so we can keep helping you with your games.