Startopia black screen with sound on startup

On certain machines Startopia can run into startup issues where you’ll only see a black screen and possibly your mouse. Some users also hear game sound when this issue occurs. One possible workaround is the following (original solution posted by mp.73):

  • Open up the DirectX control panel. Press the Start button Picture of the Start button, and type dxdiag in the Search box, and then press ENTER.
  • Enable “Use ModeX for 320 by X(DX7-)”. From within the DirectX control panel, switch to the directdraw tab and select the group tab labelled performance. From here enable “Use ModeX for 320 by X(DX7-)”.
  • Run Startopia again. If everything worked as expected you should now land on the main menu on your first try.

If you’ve followed the above steps and are still having trouble with the Startopia black screen issue, please post in the comments below. To increase your chances of a solution being found include as much detail as possible (which version of the game you’re running, what operating system you have, what video card you have and steps to reproduce the issue). Screenshots are also very useful!

sources: link 1

Share on Google+0Share on Reddit0Share on StumbleUpon0Tweet about this on TwitterShare on Facebook0Digg this
    William
    September 19, 2014 at 9:54 am

    NVIDIA GTX660 with windows 7, I have installed original game with two patches 1.01 and 1.01b from this website. Run the game with windows98 compat and did the trick here, but I still have a black screen, without mouse and only the sound. I know the keyboard input works too, since I can skip intro by pressing escape.

Leave a Reply to William Cancel reply

Search
Questions!?
Play nice
>> All posts, unless specified otherwise, are original and created solely for The Game Engine. Please credit anything you use or reference from this site.
Was this site helpful?
>> The Game Engine is a non-profit personal project. Please consider a small donation so we can keep helping you with your games.