Age of Mythology square fog of war and water glitch

Age of Mythology is known to have fog of war and water texture issues on computers with unsupported video cards, especially Intel integrated graphics chips. The reason for this issue is that Age of Mythology defaults to very poor graphical presets if it can’t identify your video card. Symptoms for this graphical glitch include:

  • Access to only a few low quality resolutions.
  • Pixelated water that isn’t transparent. The effect can be seen in the image below. Rather than seeing the sea bed the water is a completely opaque blue.
  • Fog of war that displays in large black squares. These squares don’t properly show your ‘true’ view range and look similar to the ones in the image below.

age of mythology square fog of war

To fix this fog of war/water glitch follow the steps below:

  1. Copy the contents of geforce3.gfx. Your geforce3.gfx file is located in:
    gfxconfig\geforce3.gfx
    gfxconfig2\geforce3.gfx (titans only)

    Open one of these files in a text editor and copy it’s entire contents. You should be able to open these files with any text editor (notepad++ for example).
  2. Overwrite the contents of all i845.gfx files with those of geforce3.gfx. The i845.gfx file is located in:
    gfxconfig\i845.gfx
    gfxconfig2\i845.gfx (titans only)

    Open i845.gfx in a text editor and overwrite all of the content with the configurations you copied from geforce3.gfx. Make sure to overwrite both copies of the file if you have Titans. Don’t change any file names. If you don’t have Titans installed you won’t have a gfxconfig2 folder so don’t worry about it.
  3. Disable anistropy. User Piet reported that the problem did not resolve for him until he disabled anisotropy in his modified i845.gfx file. To disable anisotropy change this line:
    anisotropy=1 // DWORD. hardcodes anisotropy on (or off), regardless of what driver says
    to:
    anisotropy=0 // DWORD. hardcodes anisotropy on (or off), regardless of what driver says

What’s happening here is that Age of Mythology doesn’t recognize your video card so defaults to the worst possible supported configuration – i845. By overwriting the contents of the i845.gfx configuration with those for the geforce3 chipset you’re tricking Age of Mythology into using the highest possible settings by default instead.

If the above steps don’t work there is a chance that you may have one of the other supported graphics card but still with very few available configurations (AKA the game won’t default to your modified i845.gfx configuration). Just like how you overwrote the default i845 gfx configuration you can use the geforce3.gfx file to overwrite your video card’s configuration file in the gfxconfig and gfxconfig2 folders. If you don’t know which file to change, you’ll have to change all the .gfx files in these folders except the ones that start with 0x (i.e. 0x3d3d_3dlabs.gfx).

If you’ve followed the above steps and are still having issues with the Age of Mythology square fog of war and water glitch, please post in the comments below. To increase your chances of a solution being found include as much detail as possible (which version of the game you’re running, what operating system you have, what video card you have and steps to reproduce the issue). Screenshots are also very useful!

sources: link 1, link 2, link 3, link 4, link 5, link 6

Share on Google+1Share on Reddit0Share on StumbleUpon0Tweet about this on TwitterShare on Facebook17Digg this
    Ethem Kundak
    April 11, 2013 at 3:34 am

    Thank you very much. I can’t find any useful information about it anywhere but here. Now I’m able to select any resolution and 32 bit color depth. Thanks a lot, you’re the best!!!

    Matthew
    May 28, 2013 at 3:43 pm

    thanks a lot! it fixed the water and fog of war glitches!
    i have a question though, when i drag a box with my cursor the box is black (and the cursor has some lag with the box) is it supposed to be outlined with black? i was watching a youtube video and his was white. Just wondering, thanks again!

      Alpaslan
      October 16, 2016 at 4:29 am

      I have the same problem. Let me know if u fixed it. I’m on GR as Alpaslan.
      bozkurtalp_87@mynet.com

    ozgur
    June 13, 2013 at 7:55 am

    thank you thank you thank you thank you very much :)

      yarkin
      September 19, 2013 at 3:51 am

      özgür abi sen türksün galiba okudun anladın banada anlatırmısın türkçe ya :D

    June 17, 2013 at 8:08 pm

    Thanks a lot… It worked perfectly. May Odin take you to Valhalla. :D

    my fog of war still has the same problem the water it´s fix but the fog
    Help !

      I had the same problem once on an old integrated graphics laptop. The steps above would only fixed the water and not the fog of war. The problem only went away after I re-installed Windows 7 after getting a new hard disk, and then installed the games again and followed the steps again.

      You must have incorrect game config stored somewhere. Try removing everything you can find for the game from your computer (uninstall, remove all folders left over, remove registry keys etc.) and then re-install and trying the steps again. Also make sure you have the latest possible video card drivers and have all relevant Windows updates installed.

      Best of luck!

    Mirez
    July 29, 2013 at 5:42 am

    I had this error when I tried to run age of mythology on windows 7 on my macbook pro. Your solution worked =)

    Thank you very much!

      drea
      August 5, 2013 at 6:18 am

      i have been looking for a workaround for years to kill the gfx glitches on my girlfriend’s oldish vista laptop with intel video chip. perfect 10/10 advice! thank you a lot. :)

      when did your post go online?

        You’re welcome! This post went online Nov 7, 2012. I think I saw some related posts a few months before that?

    Kevin
    August 4, 2013 at 12:15 pm

    Worked perfectly, thank you so much!!! Now if only I could get the opening cinematic to work…

    Piet
    September 5, 2013 at 4:19 am

    If some people (like me) still have the glitch problem after applying this “patch”, try the following:

    • Open your NEW i845.gfx file (the renamed geforce3 file)
    • Adjust parameter: anisotropy from 1 to 0. This will require changing this line:
      anisotropy=1 // DWORD. hardcodes anisotropy on (or off), regardless of what driver says
      to:
      anisotropy=0 // DWORD. hardcodes anisotropy on (or off), regardless of what driver says

    This fixed the problem on my intel igp.

      Thanks for posting your solution. I’ll add it to the steps above :)

    Luis
    September 24, 2013 at 3:21 pm

    it fixed my water graphics problem, but don’t fixed my resolution problem. My computer resolution is 1366×768, and even if I put the biggest resolution avaliable in settings, it still in 1280×1024

    September 29, 2013 at 11:12 pm

    I LOVE YOU WHOEVER DISCOVERED THE “anisotropy=0” IT REALLY WORKED! I rememeber playing this game when i was like 8! I still love it at 16

    Joel Guedes
    October 1, 2013 at 8:57 am

    OMG this is really amazing, this really works, i was ready to stop trying to play but thanks to this post i’ve done it, thank you very much, you are the best

    Selien
    November 27, 2013 at 7:09 am

    Thank you for this, it worked!! You’re my hero!! Greetings from the NL!

    Jeppe
    December 2, 2013 at 6:09 am

    Thank you so much the made my day. :D

    A Guy
    December 10, 2013 at 10:44 pm

    Yup worked like a charm for me :D

    Steve Sims
    December 21, 2013 at 2:22 pm

    Did everything listed here. Even rewrote all the gfx as indicated. Still have original issue with fog of war and water. Oddly, the water will sometimes “fix” itself after playing the game for a bit and look like it is supposed to, but the fog of war never corrects.

    Fully updated game, running Windows 8.1, but had the problem in simple 8 as well. Intel HD graphics 4000, so not a powerhouse, but it runs all the other animations and higher graphics of the game perfectly fine.

      I’ve never tried this fix on Windows 8 but the principle should be the same. With integrated graphics cards the problem is often that the game tries to pick a very low GFX configuration because it cannot recognize your card.

      I wish it wasn’t such a brute force solution, but I haven’t yet found a way to see which GFX configuration specifically the game is using. The only thing I can suggest, which you have probably already done, is to make sure all GFX files (both in gfxconfig and gfxconfig2) are overwritten with the contents of your geforce3.gfx file. If you find a way to see which GFX file the game picks up, or if you have any other info on the topic please let me know.

        Steve Sims
        December 24, 2013 at 10:49 pm

        I reinstalled and repeated the basic steps above (for i845 and anisotropy). This time it worked as expected and looks great. I must’ve miscopied something in my prior efforts. This fix appears to be verified for Windows 8.1, at least on my machine. Thanks for all the help!

          I’m glad to hear it! Thanks for following up and verifying the fix. Happy holidays :)

    Barg
    January 4, 2014 at 7:32 am

    thanks it worked for me. on a laptop with Intel HD graphics 4400.

    Rohan
    January 11, 2014 at 11:17 am

    Anyone know how to fix this on Windows 8? If you do can you give me a step-by-step, Thanks

      Have you tried the above steps? This fix has been verified on Windows 8 by other users. If you’ve tried it and are still running into problems it might be worth reinstalling and trying again.

    Chris
    January 20, 2014 at 12:48 pm

    If you have this problem on windows 8 there will be a file inside named geforce3 copy it, rename it to i845 and delete the old i845.

    Thank you very much, it works ! (I can only use my intel chips)

    Mark
    February 3, 2014 at 11:20 pm

    where do I save the revised I815 file? Always says “you can’t save here” when I try

    ScaryNinja
    February 8, 2014 at 6:15 pm

    Perfect fix for everything, thanks so much!

    Pascal
    February 18, 2014 at 2:21 pm

    Thank you very much!! I’m so glad, the game is way more enjoyable now :)

    cjhrjone54
    February 19, 2014 at 3:14 pm

    Thanks so much! I’ve had this problem for a while now but I just thought it was an issue with my video drivers, so I never bothered to look online for a possible solution – until now! Now I can play just like I used to! Thanks so much again!! :D

    gloomy
    February 22, 2014 at 5:50 am

    I want to thank you very much for this fix.Because my amd card has got toasted, I was forced to play with integrated intel graphics. The fact that it screwed with AoE annoyed me the most and when I saw that there was a fix for it , I was relieved. I want to thank you again for this. Not too often I see this type of tutorials that actually work.

    Lucas
    February 24, 2014 at 11:49 am

    It works! Thank you so much!!!

    Raimo
    February 25, 2014 at 2:50 am

    U are the best! :D

    Jonatas
    February 25, 2014 at 7:45 am

    it worked, thank you mate!

    Dael
    March 17, 2014 at 1:47 am

    Thank you so much!!!!!! Finally playing as it is supposed to.
    No information anywhere on the web but here. Thanks a lot again!
    Regards from México.

      Thanks for the kind words! I’m glad it worked for you :)

    Warpsoldier
    March 24, 2014 at 11:21 am

    I have an Alienware 14 Windows 8 laptop, I entered everything from Geforce3.GFX file into every other .GFX file save the ones starting with 0 and it still failed-no water fix or FOW fix its also messed up my Editor, what now?

      Can you clarify what you mean by it messed up your editor? Do you mean you also see the water/FOW bug there as well?

      Also have you tried disabling Anisotropy (step 3 above) in your Geforce3.gfx file before using it to overwrite the contents of your other gfx config files?

        wq
        March 25, 2014 at 4:22 pm

        I have now fixed this error but many thanks for all the help anyway.

          Can you share your solution? It might help someone else with a similar issue.

            Warpsoldier
            March 26, 2014 at 2:14 am

            Well I reinstalled the game with the reinstall option and now it runs perfect every time only problem is whenever I alter the in-game options the colours on editor turn to yellow and white.

    zzozribberonioo
    March 28, 2014 at 12:46 pm

    Great stuff man. :) Thank You. I managed to run the game on Linux Mint 16 with the latest wine, and this finally fixed the problem.

    To the people who still have problems after doing all of the described above – You might need a clean install.

    To anyone who wouldn’t like to bother with renaming all the files, here they are, with backups of the originals:
    http://www.mediafire.com/download/6a4nk3kirxi2u6l/AoMy_water_and_fog_of_war_graphic_bug_fix_(copy_contents_to_freshly_installed_game_dir).zip

    Herni
    April 27, 2014 at 8:32 pm

    Hi!
    I just edited all the GFX files in gfxconfig2, but still have the problem of no video when the game starts, square fog and water.
    I’m on windows vista enterprise and Inter(R) HD graphics.

    Any ideas?

    Thank you.

      Make sure you copy the contents of your geforce3.gfx, into the appropriate gfx files mentioned above in both your gfxconfig and gfxconfig2 folders.

    FijianDude
    May 3, 2014 at 3:54 am

    OMG….. Thank you very much….. this helped alot! I was about to give up playing AoM until i found this!!!!! A lot of thanks to you! :)

    AoM
    May 6, 2014 at 8:28 pm

    THANKS A LOT!!!!!

    samuelgsuttonSam
    June 3, 2014 at 10:59 am

    Thanks alexgophermix, this issue was doing my head in and the rest of the information on the internet regarding this problem (or lack thereof) was utterly useless. Thanks again.

    Jack Kumbill
    July 20, 2014 at 8:37 am

    Thank you so much for this. Really worked. ive been playing this since i was ten and im half fifty now but still play once in a while and this tip has been terrific.

    One question though. Now that ive done what you said, when i click on units and then command right click them on other objects, whether it is walls, buildings , trees or other units, IT FLASHES. like, they flash literally for a brief moment…. and i dont quite like it tbh. i wish it didnt flash. ive tried looking at the possible differences between the two codings (betwen geforce3 and i845) but still cant tell which one makes that difference. do you know anything of this matter?

    If you dont, i still thank you greatly for this great tip ^^

      So glad to hear you can enjoy an old classic again :) I haven’t actually heard of the issue you mentioned before, but it is listed on microsoft support page for AOM. They suggest the following:

      When you try to use a high resolution setting, you see brief flashing. This behavior may occur when you use an old video adapter. This behavior does not affect game performance or stability.

      To resolve this behavior, quit Age of Mythology, use the Age of Mythology Safe Video shortcut under Diagnostics to restart the game, and then switch to a lower resolution under Options.

      Note Age of Mythology requires that graphics hardware acceleration be turned on. You may see the mouse cursor with the black screen in the background if 3D acceleration is turned off.

      Source: http://support.microsoft.com/kb/331147

      Let me know if that works for ya

    Justin
    September 23, 2014 at 7:59 pm

    a faster way is to just delete the i845 file then rename the GeForce3 file to i845 works like a charm. (I did this because the computer wont let me save the edited i845 file
    )

      You bring up a good point. If you don’t know which configuration file you game will use you could probably just delete all except for GeForce3 and rename it to i845.

    Cyke
    October 7, 2014 at 9:00 am

    I’ve got Titans but not gfxconfig2 Folder, only the gfxconfig and changing the files in this Folder didn’t help
    But maybe i’ve got bugs because the game was developped for Windows xp and I’ve got 8.1…

    Oz
    October 17, 2014 at 8:10 pm

    I tried to do it the way recommended but I kept get “initialisation failed”. I then tried it the way some others have suggested (the delete and rename method) and that worked fine. Much obliged because I really like AOM, but haven’t been able to play it for a bit.

    tyler
    November 10, 2014 at 9:29 am

    Thanks a bunch! Very surprised to say works great on ported AOM gold, OSX 10.9, Intel iris 5100.

    The only issue that still remains: Even though the resolution options are all available in settings, choosing a widescreen res (1600×1200) doesnt seem to change anything. Still square screen with no res increase obvious.

      tyler
      November 10, 2014 at 9:30 am

      Wineskin wrapper version 2.6.0; engine ws8wine1.4

    Supmegamason
    November 19, 2014 at 3:28 pm

    Thanks Bro!

    qoixiop
    December 26, 2014 at 10:26 am

    it works, thank you, you are de best

    Ragnar
    March 11, 2015 at 2:22 am

    THANK U SO MUCH!

    Kaane
    March 12, 2015 at 12:35 am

    Tried to start this up for nostalgia on my Win 8.1, this exact video glitch happened, and I was like ARE YOU KIDDIN.

    But thankfully, I found this after I saw the official windows help page for this was useless. Thanks a lot, seriously. This also happens to be the first time I ever modified a game’s files besides some simple run of the mill modding…felt pretty epic XD.

    Anyways, thanks a bunch ^^.

    djukamedar
    March 26, 2015 at 2:00 am

    i tried this, but when i try to overwrite i845.gfx file and save it it says: error saving , access is denied. i dont know what is the problem, can you help me. sorry for bad english

      Access is probably denied because you don’t have the right privileges to edit this file. Make sure it’s not read-only and try editing it as administrator.

    Yoshi
    April 5, 2015 at 8:00 am

    this worked superb! but I realized another problem when I was done… the unit-description is incomplete now… I cannot see population-cost for units and not see the typical text “counter-archer, this unit is good against archers only” anymore… any Ideas?

    nils holgersson
    April 25, 2015 at 11:59 am

    You Sir, are awsome! Thank you so much! :)

    Sebastian
    May 24, 2015 at 6:04 pm

    You deserve some nasty head man

    John
    May 28, 2015 at 8:10 pm

    Dude!!!! Is working perfectly!!! You’re the best! Thanks!

    Arnold
    May 31, 2015 at 5:32 am

    Thanks a lot man, you really helped me out! Just perfectly :D.

    YUSSUF
    July 3, 2015 at 6:22 pm

    Thank you , it’s perfect

    Michael
    July 8, 2015 at 9:11 am

    Whenever I try to change anything I get a pop up saying the CD ROM is read-only but when I try to fix that in the properties tab, I always get the same pop up saying access denied…? Not sure what to do. (P.S. I’m the administrator so I don’t think that’s the problem)

      You should be changing the properties of the .exe files in your game install folder e.g. C:\Program Files\Age of Mythology not your CD. CD-ROMs are write protected, you can’t edit them like that

    Red_Natto
    July 19, 2015 at 11:38 am

    Thank you so much! first time I ever used notepad++ and it worked perfectly! now the graphics problems are gone, thanks again :)

    Fontaine
    August 26, 2015 at 10:44 pm

    Hey,

    I tried doing this, but it said I need to be an administrator to edit the file over. Only problem is, my account is an administrator. Anything I can do?

    Best,

    Talmon Filho
    September 5, 2015 at 8:08 am

    Thank you very much, man!! You helped me a lot!!
    Just even after I fixed this glitch, I still can’t see the “Ensemble Studios/Microsoft Studios” logo animation at the very beginning of the game, but… who cares! right?? XDD

    Nora
    September 10, 2015 at 12:12 am

    Thank you so much! Worked perfectly for me on Windows 8.1

    SerNilrem
    October 9, 2015 at 2:10 am

    Wow, thank you so much, I thought I had been condemned to the ugliest game ever, but you saved me. Being a total noob I had no idea about the method you used but the steps were easy to follow so thank you thank you thank you!!

    Maneesh
    October 9, 2015 at 8:10 am

    Thank you….

    MiTsuki
    January 20, 2016 at 9:29 am

    Perfection. Thank you!!

    Its Just Not Funny
    February 7, 2016 at 2:43 pm

    I have absolutely no idea how to find gfxconfig2\geforce3.gfx

    Have only just come across to Linux Mint (17.3) from Windows 10 and while I’m glad to have made the swap, discovering ‘The Insurmountable List of Simple Things You Don’t Know’ (that old time Linux users take for granted) is just overwhelming.

    Does anyone have the patience to explain where to find these files please?

      the gfxconfig2 folder is inside your Age of Mythology installation folder wherever you placed it. It has nothing to do with Linux (though trust me I know that feeling)

    SnowyKaktus
    March 3, 2016 at 1:16 am

    Thank you so much.
    It worked on my 2015MBPr running OS10.11.2 and no need for step3 here.

    OdinTheBest
    April 13, 2016 at 6:29 am

    Thank you so much! I thought the problem was related to my macbook.

    Scylla
    April 19, 2016 at 3:06 am

    Don’t know how to access this anisotropy setting?

      You change you anisotropy settings manually in you config file as mentioned in step 3

    Jarik
    May 25, 2016 at 3:28 pm

    Worked perfectly on Dell laptop with windows 10, GeForce GT 650M and intel integrated gpu.
    Thank you very much for your help.
    Kind regards from Greece.

    tariq
    July 20, 2016 at 11:01 am

    hi , i don’t have this problem , in the game , but when i started to play online on voobly , i got this problem , i did this , still not fixed

    Casian
    August 18, 2016 at 1:23 am

    Problem fixed. Thanks :)

    Ploggy344
    November 12, 2016 at 1:52 am

    Thanks! it worked.

    November 14, 2016 at 3:07 pm

    Thanks bro, greetings from Venezuela

      No problem friend, glad I could help. Greetings from Canada :)

    Mat
    December 23, 2016 at 5:37 am

    Awesome! I’m playing AoM on MacOS with the Iris Pro 5200 graphic card and Step 1 and Step 2 were enough to do, to solve the problem with the fog of war.

    Josseph
    May 29, 2017 at 8:11 pm

    it worked great!

Leave a Reply to tyler Cancel reply

Search
Questions!?
Play nice
>> All posts, unless specified otherwise, are original and created solely for The Game Engine. Please credit anything you use or reference from this site.
Was this site helpful?
>> The Game Engine is a non-profit personal project. Please consider a small donation so we can keep helping you with your games.